Create files and write to files of PANTARIS storage using mounted volumes


  • I am trying to create files in PANTARIS storage using docker-compose
    which is not creating.

  • Also when I create file in the volume mounted in the container it gets created, but when try to write to the file the contents will get empty after a minute.

Can you help me to resolve these issues.

You have two options regarding volumes.

  1. You can just use volumes without This will create a volume (persistent data).
  2. If you use label with project, it will use the storage from the project where the app is started. This will be mounted via davfs2 (webdav). For this to work, you have to enable “network storage” in the project in which you start the app.

You can find more information about the second option here: Documentation | PANTARIS

I hope this helps.
If you still have issues I need more information, like the instance id / endpoint or docker-compose and code snipped.

version: "3.7"

    build: ./api
      - my-volume:/mnt/data

    labels: project /data/ false

this is how i am mounting the volume,

In data folder I am creating the file and writing to it, But contents gets empty after a minute.

Currently I am testing in free plan app.

Ok, I looked, and everything seems in order at first glance.
Could something interfere with your application?

We must look deeper if you’re sure it should work on your end.

Also, did you check if you can see the created folders/files within the project storage view?
If I remember correctly, you must ensure the folder /data exists in the project.

Folder exist
But data stays only for a minute, I even tried writing file directly from Kubernete Dashboard issue is same.

In the Pantaris platform I don’t see the files. But it is there in Persistent Volume

Ok. I forwarded this to a college. We have to look deeper into this issue.
Can you start the sandbox app and let it run?


Currently I have reverted the code in the sandbox app.

But with that docker-compose settings we can reproduce it.

I tired this feature and it seems to work.
It would be helpful to pinpoint this if you could

  1. Create a demo app “project files” (when creating an app, check the demo app) and start it in the same project. You should see all folders/files within the project.
  2. If this succeeded, could you try within your app to remove so it mounts the root folder and sees if this works?

Thanks a lot

I tried this and I was able to see all project folders and files, but unable to write to any files.

Any updates on this.?

Sorry for the late response.
There are some internal talks about this, and maybe some leads on what this could be.
Within our test suite, everything works fine.

Could you let us know the instance id?
Also is it ok that we look into your project/application what the cause could be?