Issue with Multiple endpoints of docker compose


I am trying to expose multiple http endpoints using docker compose with help of Documentation | PANTARIS

Below is my docker compose file

Currently frontend web is loading but backend is giving 404 with url
e.,g, api-<instance id>

please help me to get the api url access to.

This is our api URL

hey, please create a ticket, which contains the instance url so the Support can take a look on your app.

hm, for some reason app in the prefix gets blocked. For a workaround you can rename backendapp to backend (service-name + label).

Like already written, create a ticket if you want to get this fixed. The forum is not a place for bug-reports. Thanks

1 Like

Hi @thomas.schuerle you could re-use a ticket of mine where I already encountered this situation. This is caused by exposing the same name via label like the docker-compose service. => Login : Calponia

I have created the ticket.

And with above suggestion the issue is still not fixed.

Thanks for the ticket.

Another person tested the workaround successfuly. Did your replace “backendapp” in line 14 and 18 in your compose file?

Yes, Just gave backend in that place it worked for me.